Phoyo ID Cross Platform Download

Please wait while you are redirected...or Click Here if you do not want to wait.

If the download does not start then click the above link to activate the redirection.

IMPORTANT

  • Java 1.6 or 1.7 or 1.8 required
  • Known issues on Ubuntu when openjdk-9 is installed
    • Workaround: uninstall openjdk-9

How to use

  • Extract the zip file content
  • Execute the following command lines:
    • cd phoyo-id-x-x-x
    • java -jar phoyo-id.jar